杰穆鲁斯图标。链接到主页
打开导航

为 Linux 安装

请确保你阅读了入门页面。

Jamulus 3.9.1 解决了一个与 MIDI 控制器相关的错误,该错误可能导致旧的推子电平丢失:如果您使用了 `--ctrlmidich`,您可以使用 `--cleanuplegacyfadersettings` 启动应用程序一次以尝试转换旧格式到新的。此选项将在未来的版本中删除。阅读 更改日志 了解更多信息。

升级?您可能需要先 备份您的配置

Debian 和 Ubuntu

我们为最常见的架构提供了三个等效的.deb 文件。请下载相应的:

对于基于 Intel/AMD 的机器 (amd64):

下载 Jamulus (.deb, amd64)

对于基于 ARM 的机器 (例如Raspberry Pi, armhf, arm64):

下载 Jamulus 32 位 (.deb, armhf)下载 Jamulus 64 位 (.deb, arm64)

在你下载了正确的文件后:

  1. 仅限 Ubuntu - 启用 Ubuntu“universe”存储库(您可以使用 基于 GUI 的方法基于 CLI 的方法)。
  2. 通过打开命令行窗口更新 apt(CTRL+ALT+T 应该可以)并输入:sudo apt-get update
  3. 转到下载安装程序的位置并双击它,或使用命令行: sudo apt install ./jamulus_3.9.1_ubuntu_amd64.deb armhf: sudo apt install ./jamulus_3.9.1_ubuntu_armhf.deb arm64: sudo apt install ./jamulus_3.9.1_ubuntu_arm64.deb
  4. 安装后,您可以删除该文件并关闭命令行窗口。

请注意,如果您需要将 Jamulus 升级到较新的版本,只需下载新的 .deb 文件并按上述方式重新安装即可。

其他发行版

对于其他发行版上的安装程序,请参阅其包管理器和 [Repology](https://repology.org/project/jamulus/versions)。如果您的发行版中不包含最新版本的 Jamulus,您可以 [从源代码编译 Jamulus](https://github.com/jamulussoftware/jamulus/blob/master/COMPILING.md)。另请注意贡献的 [安装脚本](https://github.com/jamulussoftware/installscripts)。

设置你的硬件

使用 QjackCtl 配置 JACK

Jamulus 客户端需要 JACK 才能运行,但您需要先配置它。推荐的方法是使用QjackCtl

  1. 启动 QjackCtl。您将看到 Qt JACK Control 实用程序主页
  2. 如下配置您的音频硬件(JACK 的确切设置将取决于您的音频硬件的能力):
  • 将音频 接口 设置为您想要的(列表中可能有几个)
  • 采样率设置为 48000
  • 首先将“帧/周期”设置为 128**,将“周期/缓冲区”设置为 2

重新启动 JACK 以使新设置生效

启动 Jamulus

随着 JACK 的运行和配置,启动 Jamulus。

如果您遇到声音中断问题(特别是 JACK/QjackCtl 报告的 XRUN 错误),请尝试设置更大的值(例如 256 帧或 3 个周期)。较低的(例如 64 帧)可以带来更好的性能,但可能会带来更多的声音问题。否则请参阅[故障排除页面](客户端故障排除)。

##全部安装完毕?

看看

入门页面